Collector Bank - Major outage
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Aug 14, 2024 - 07:53 UTC
Investigating
We are currently investigating an issue with Collector Bank.
Posted Jun 21, 2024 - 08:17 UTC
This incident affected: Collector Bank.