Skandia Payments - Partial outage
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Nov 21, 2024 - 18:17 UTC
Investigating
We are currently investigating an issue with Skandia.
Posted Nov 21, 2024 - 15:44 UTC
This incident affected: Skandia.