Swedbank - Degraded performance affecting Investments

Incident Report for Tink providers Sweden

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 21, 2025 - 14:40 UTC

Investigating

We are currently investigating an issue with Swedbank affecting Investments.
Posted Mar 06, 2025 - 13:54 UTC
This incident affected: Swedbank.