Collector Bank Major Outage
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 10, 2024 - 09:03 UTC
Identified
We have identified the cause of the issue and are working on it.
Posted Mar 14, 2024 - 14:20 UTC
Investigating
We are currently investigating an issue with Collector Bank.
Posted Mar 14, 2024 - 14:20 UTC
This incident affected: Collector Bank.