Nordea - Partial Outage
Incident Report for Tink providers Sweden
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 11:21 UTC
Identified
We have identified the issue and are in contact with Nordea for further information.
We will update when a significant change to the situation occurs.
Posted Nov 25, 2022 - 07:00 UTC
This incident affected: Nordea.