ICA banken - Major Outage
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 18, 2024 - 16:01 UTC
Identified
We have identified the issue and are in contact with Ica banken for further information. Account information and payment initiation are affected. There is a problem with logging in on the web and in the app.
We will update when a significant change to the situation occurs.
Posted Apr 18, 2024 - 15:03 UTC
This incident affected: ICA Banken.