Nordea Direct Access - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Sweden

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 07:41 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jun 24, 2025 - 20:14 UTC
This incident affected: Nordea (Nordea | Direct Access).