CSN major outage

Incident Report for Tink providers Sweden

Resolved

This incident has been resolved.
Posted Jun 28, 2022 - 14:28 UTC

Investigating

We are currently investigating an issue with CSN.
Posted Jun 28, 2022 - 07:10 UTC
This incident affected: CSN | Direct Access.