Handelsbanken Open Banking - Major outage affecting Payment Initiation & Account Information

Incident Report for Tink providers Sweden

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 20, 2025 - 15:37 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 20, 2025 - 15:16 UTC
This incident affected: Handelsbanken.