Länsförsäkringar partial outage
Incident Report for Tink providers Sweden
Resolved
This incident has been resolved.
Posted Jun 27, 2022 - 15:32 UTC
Investigating
We are currently investigating an issue with Länsförsäkringar.
Posted Jun 27, 2022 - 12:28 UTC
This incident affected: Länsförsäkringar.