Issue with Payments - Skandia | Open Banking

Incident Report for Tink providers Sweden

Resolved

We experienced an outage in the payment flow for Skandia | Open Banking between 14:50 and 14:58.

No payments during this period where successful.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Jun 24, 2025 - 14:22 UTC
This incident affected: Skandia (Skandia | Open Banking).