ICA Banken - partial outage
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 02, 2024 - 12:54 UTC
Investigating
We are currently investigating an issue with ICA Banken.
Posted Dec 01, 2024 - 17:18 UTC
This incident affected: ICA Banken.