ICA Open Banking - Degraded performance in Payment Initiation services

Incident Report for Tink providers Sweden

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Aug 25, 2025 - 09:13 UTC

Investigating

We are currently investigating an issue with ICA.
Posted Aug 24, 2025 - 06:32 UTC
This incident affected: ICA Banken (ICA Banken | Open Banking).