Skandia payments unavailable
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Jun 29, 2022 - 06:49 UTC
Identified
We have identified the issue and are in contact with Skandia for further information.
We will update when a significant change to the situation occurs.
Posted Jun 29, 2022 - 05:51 UTC
This incident affected: Skandia.