ICA Banken - Partial outage

Incident Report for Tink providers Sweden

Update

The Provider: icabanken-bankid Is currently unavailable.
We are investigating the issue.
Posted Feb 10, 2025 - 10:19 UTC

Investigating

We are currently investigating an issue with ICA Banken.
Posted Feb 10, 2025 - 10:17 UTC
This incident affects: ICA Banken.