SEB - Payments Unavailable
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Nov 14, 2022 - 10:18 UTC
Identified
We have identified the issue and are in contact with SEB for further information.
We will update when a significant change to the situation occurs.
Posted Nov 14, 2022 - 08:02 UTC
This incident affected: SEB.