American Express - Degraded performance
Incident Report for Tink providers Sweden
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 07:36 UTC
Investigating
We are currently investigating an issue with American Express.
Posted Apr 24, 2024 - 18:20 UTC
This incident affected: American Express.