Nordea Open Banking - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Sweden

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Apr 02, 2025 - 11:32 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 02, 2025 - 10:59 UTC
This incident affected: Nordea (Nordea | Open Banking).