Nordea OB - PIS degraded performance

Incident Report for Tink providers Sweden

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 09:41 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jun 09, 2025 - 09:38 UTC
This incident affected: Nordea (Nordea | Open Banking).