Länsförsäkringar - Degraded performance affecting Investments
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 09, 2024 - 07:17 UTC
Identified
We have identified the issue since 07th Nov and we will update when a significant change to the situation occurs.
Posted Nov 22, 2024 - 17:01 UTC
This incident affected: Länsförsäkringar.