American Express open banking - Degraded performance
Incident Report for Tink providers Sweden
Identified
We have identified the issue and are in contact with American Express for further information.

We will update when a significant change to the situation occurs.
Posted Oct 03, 2023 - 07:35 UTC
Investigating
We are currently investigating an issue with American Express.
Posted Oct 03, 2023 - 07:25 UTC
This incident affects: American Express.