ICA Banken - Major outage affecting Account Information and Payment Initiation
Incident Report for Tink providers Sweden
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 14, 2024 - 07:04 UTC
Identified
We have identified the issue and are in contact with ICA Banken for further information.
We will update when a significant change to the situation occurs.
Posted Apr 13, 2024 - 21:13 UTC
This incident affected: ICA Banken.