Handelsbanken Open Banking - Degraded Performance

Incident Report for Tink providers Sweden

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Apr 24, 2025 - 08:28 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 24, 2025 - 07:46 UTC
This incident affected: Handelsbanken (Handelsbanken | Open Banking).